Базовая конфигурация коммутатора Cisco

В данной статье пойдет речь о типичной для моего места работы начальной конфигурации коммутатора Cisco на примере c3750x-24.
При первом включении, после долгой загрузки коммутатор выдаст предложение начать диалог стартовой конфигурации:

Would you like to enter the initial configuration dialog? [yes/no]:

Отвечаем «no» и получаем приглашение следующего вида: «Switch>»

Для начала необходимо перейти в так называемый «привилегированный режим». Привилегированный режим на коммутаторах Cisco, грубо говоря, является аналогом superuser’а в *nix системах и прав администратора в Windows. Переход в привилегированный режим выполняется командой «enable».
После ввода команды приглашение поменяется на «Switch#»:

Switch>enable

Switch#

Теперь перейдем в режим конфигурации коммутатора командой «configure terminal» (или «conf t») и поменяем имя коммутатора:

Switch(config)#hostname TVER-ASW-02

Следющим шагом зададим пользователя «admin» и пароль для него:

TVER-ASW-02(config)#username admin privilege 15 secret 0 <пароль>

Разберем данную команду поподробнее:

  • privilege указывает на уровень привилегий для данного пользователя от 0 до 15 (15 — самый высокий);
  • secret указывает на то, что пароль будет храниться в конфигурации в зашифрованном виде (если вместо secret написать password то пароль будет храниться в виде текста);
  • (опционально) число после secret указывает на то, в каком виде вы будете вводить пароль далее: 0 — незашифрованный («plain text»), 5 — хешированный по MD5, 8 — хешированный по PBKDF2, 9 — хешированный по SCRYPT. Данное число можно не указывать, если вы будете вводить пароль в незашифрованном виде (т.е., «0» можно не указывать, а просто ввести пароль).

Дальше зададим пароль на привилегированный режим (синтаксис команды такой же, как и при задании пароля для пользователя):

TVER-ASW-02(config)#enable secret 0 [пароль]

Теперь перейдем к настройке aaa (authentication, authorization, accounting)

TVER-ASW-02(config)#aaa new-model

TVER-ASW-02(config)#aaa authentication login vty local

TVER-ASW-02(config)#aaa authorization network default if-authenticated

Затем настроим порядок аутентификации по telnet

TVER-ASW-02(config)#line vty 0 4

TVER-ASW-02(config-line)#login authentication vty

TVER-ASW-02(config-line)#exit

TVER-ASW-02(config)#line vty 5 15

TVER-ASW-02(config-line)#login authentication vty

TVER-ASW-02(config-line)#exit

Дальше нужно дать коммутатору IP адрес для того чтобы в дальнейшем можно было его конфигурировать и мониторить.

Зачастую, для удобства и безопасности, интерфейсы управления устройствами выделяют в отдельную подсеть и VLAN.
У меня на работе это VLAN 10 и подсеть 10.10.10.0/24.
Соответственно, далее нам нужно объявить VLAN 10 на коммутаторе:

TVER-ASW-02(config)#vlan 10

TVER-ASW-02(config-vlan)#name Management

TVER-ASW-02(config-vlan)#exit

Мы объявили на устройстве VLAN 10 и дали ему имя «Management», следующим шагом назначим коммутатору IP-адрес 10.10.10.112 в этом VLAN’е:

TVER-ASW-02(config)#interface vlan 10

TVER-ASW-02(config-if)#ip address 10.10.10.112 255.255.255.0

TVER-ASW-02(config-if)#exit

И зададим порты которые являются членами данного VLAN’а:

TVER-ASW-02(config)#interface gigabitEthernet 1/0/24

TVER-ASW-02(config-if)#switchport mode access

TVER-ASW-02(config-if)#switchport access vlan 10

TVER-ASW-02(config-if)#exit

Если компьютер с которого вы будете управлять на коммутатором находится в этой же подсети, то этого достаточно, но в моем случае все не совсем так, я попадаю в эту подсеть через маршрутизатор, поэтому нужно указать на коммутаторе адрес шлюза по умолчанию:

TVER-ASW-02(config)#ip default-gateway 10.10.10.1

Теперь можно испытать доступность коммутатора, подключив его 24 портом в нужную нам сеть и проверив доступность по telnet. Дальнейшую конфигурацию можем проводить удаленно (не через консольный порт).

Наконец не забываем сохранить выполненную нами конфигурацию, командой «write»

TVER-ASW-02(config)#exit

TVER-ASW-02#write

Building configuration...

[OK]

На этом первоначальную настройку можно считать завершенной, можно переходить к более детальной настройке коммутатора.

Эта запись была опубликована в Cisco.
Занести в закладки: ссылка.

Оставить комментарий

Ваш адрес электронной почты не будет опубликован. Обязательные поля помечены *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>